Forum closed. New forum available at http://community.wymeditor.org/

WYMeditor not working integrated in SAP GUI

Support forum for WYMeditor.

WYMeditor not working integrated in SAP GUI

Postby Stetze on Thu Oct 30, 2008 10:19 am

Hey everybody.

We wanted to use the (great) WYMeditor in an ESS-Web Application integrated in the SAP GUI.
But while the editor is working fine while testing the application in the standalone internet explorer it won't work while the bsp-application is shown in the SAP GUI environment.

Following happens while integrated in SAP GUI:
- the editor shows up
- all buttons and the input field are shown correctly
- if you click into the input field (iframe) nothing happens (the cursor does not appear inside)
- you can insert text via the 'paste from word'-function
- you can mark up the text (bold, italic, bullet points, etc.)
- but you CAN'T step into the wysiwyg-text (iframe) to insert more text, spaces ore line breaks
- you CAN insert text via the 'toggle html'-function and the text is shown below in the wysiwyg-input field (iframe)

What could be the reason for that behaviour? Which Javascript function does not work? Is there a chance to fix this (because if not we would have to run the app outside sap and this would destroy the application design)

Thanks in adavance for your help!
Stetze
 
Posts: 2
Joined: Thu Oct 30, 2008 10:08 am

Re: WYMeditor not working integrated in SAP GUI

Postby Stetze on Thu Oct 30, 2008 3:43 pm

the problem is very strange. :)

as I know discovered the editor works when the page is loaded the first time. but when a button/link is pressed the editor won't work anymore.

is there a possibility to set the cursor manually into the iframe?
Stetze
 
Posts: 2
Joined: Thu Oct 30, 2008 10:08 am

Re: WYMeditor not working integrated in SAP GUI

Postby mr_lundis on Mon Nov 03, 2008 6:28 pm

Hello Stetze, and welcome to the WYMeditor forum!

It sounds like there is some kind of collision between the WYMeditor code and your application GUI.

Are you getting any JavaScript errors?
Jonatan Lundin - designer, developer and forum moderator. You should follow me on Twitter!
mr_lundis
 
Posts: 335
Joined: Sun Dec 02, 2007 10:59 am
Location: Sweden


Return to Support

Who is online

Users browsing this forum: No registered users and 3 guests

cron