Forum closed. New forum available at http://community.wymeditor.org/

non-functional in IE7?

Support forum for WYMeditor.

non-functional in IE7?

Postby avonderluft on Thu May 06, 2010 8:28 pm

I'm sure this has come up, but I have not found a definitive answer yet.
When using the straight release out of the box, the WYM textarea does not display properly in IE.
See out of the box WYMeditor integration example below, rendered (not) in IE.

Is there any help for this? I'd love to use WYM, but sadly my user-base is mostly IE.

Screen shot 2010-05-06 at 1.18.17 PM.png
Sample in IE
Screen shot 2010-05-06 at 1.18.17 PM.png (31.73 KiB) Viewed 4011 times
--
Andrew vonderLuft
User avatar
avonderluft
 
Posts: 3
Joined: Thu May 06, 2010 8:11 pm

Re: non-functional in IE7?

Postby mr_lundis on Sun May 16, 2010 12:14 pm

I cannot reproduce this. Does the online examples work for you?
http://files.wymeditor.org/wymeditor/tr ... basic.html

Cheers! ;)
Jonatan Lundin - designer, developer and forum moderator. You should follow me on Twitter!
mr_lundis
 
Posts: 335
Joined: Sun Dec 02, 2007 10:59 am
Location: Sweden

Re: non-functional in IE7?

Postby avonderluft on Wed Jun 09, 2010 6:52 pm

Yes, that online example does in fact work for me. I have since tested and debugged and found that is was my problem:

This is from some wrapper js, for the implementation I'm using for Radiant CMS
All other browsers tested, except IE, understand multiple css elements, passed as a name argument

1 { name: 'p.important_link, p.download_link',
2 css: 'border: 2px solid 036; background-color: #f6d84c;'},

In order to accomodate IE, separate out all elements in this array:

1 { name: 'p.important_link',
2 css: 'border: 2px solid 036; background-color: #f6d84c;'},
3 { name: 'p.download_link',
4 css: 'border: 2px solid 036; background-color: #f6d84c;'},
--
Andrew vonderLuft
User avatar
avonderluft
 
Posts: 3
Joined: Thu May 06, 2010 8:11 pm

Re: non-functional in IE7?

Postby mr_lundis on Fri Jun 11, 2010 2:05 pm

There's a fix for this in trunk now.
http://trac.wymeditor.org/trac/changeset/667

Cheers! ;)
Jonatan Lundin - designer, developer and forum moderator. You should follow me on Twitter!
mr_lundis
 
Posts: 335
Joined: Sun Dec 02, 2007 10:59 am
Location: Sweden


Return to Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron