Forum closed. New forum available at http://community.wymeditor.org/

open new windows

Discuss features, code, contributions, ideas, suggestions, ...
For bugs, patches and feature requests, please post on the Trac:
http://trac.wymeditor.org/

open new windows

Postby paul mccarthy on Wed Dec 19, 2007 4:09 pm

Hi, just looking for a little help. I've noticed that when the image new window is returned without the alternate text box completed then the alt attribute is missing. this is not great in terms of accessibilty. In the alternate box isn't completed then the alt attribute should be alt="".

I would like to fix this myself but am not sure how the new window information is being returned to the main editor. If somebody could point me in the right direction I'd bevy very happy!!!

thanks,

Paul
paul mccarthy
 
Posts: 1
Joined: Wed Dec 19, 2007 4:03 pm

Postby magico on Fri Dec 21, 2007 3:41 pm

and how about not opening windows? But "frames" like lightbox?
magico
 
Posts: 2
Joined: Fri Dec 21, 2007 3:38 pm

Postby paperscissors on Tue Feb 12, 2008 5:55 pm

i think both the popups and frames ala lightbox aren't the best way to do this... the best way (in my opinion, of course) would be to show/hide these dialogs directly above the editor, to keep them in context in a non obtrusive sort of way... trying to figure this out now... but if i see the tag insertion code in my travels i will let you know...
paperscissors
 
Posts: 9
Joined: Tue Feb 12, 2008 4:41 pm

Postby hinch on Wed Feb 13, 2008 1:55 am

Give it a default value?

Code: Select all
dialogImageHtml: "<body class='wym_dialog wym_dialog_image'"
            + " onload='WYM_INIT_DIALOG(" + WYM_INDEX + ")'"
            + ">"
            + "<form name='edit'>"
            + "<h3>{Image}</h3>"
         + "<fieldset>"
            + "<label>{URL}</label>"
            + "<input type='text' class='wym_src' name='image' value='' />"
           + "<a ...>Browse Server</a>"
            + "<label>{Alternative_Text}</label>"
            + "<input type='text' class='wym_alt' value='Image'/>"
            + "<label>{Title}</label>"
            + "<input type='text' class='wym_title' value='' />"
            + "<hr />"
            + "<input class='wym_submit' type='button'"
            + " value='{Submit}' />"
            + "<input class='wym_cancel' type='button'"
            + "value='{Cancel}' />"
            + "</form>"
            + "</fieldset>"
            + "</body>",
hinch
 
Posts: 8
Joined: Wed Sep 19, 2007 5:06 pm


Return to Developers

Who is online

Users browsing this forum: No registered users and 1 guest

cron