Forum closed. New forum available at http://community.wymeditor.org/

IE8 compatibility

Discuss features, code, contributions, ideas, suggestions, ...
For bugs, patches and feature requests, please post on the Trac:
http://trac.wymeditor.org/

IE8 compatibility

Postby Jacopo on Sat Mar 28, 2009 4:16 pm

Hi, I tried the WYMeditor 0.5 beta under Internet Explorer 8 and it looks very weird. It looks fine in compatibility view.
Should I just add <meta http-equiv="X-UA-Compatible" content="IE=7" /> to the page? Or is work on IE8 compatibility done in trunk?

By the way, I just released a new version of MeanEditor. The code should be much cleaner now. It is hosted on github.
A lot of functionality is still missing (since MeanEditor is taking part in the usability survey for Wikipedia, my focus has been on technical questions, browser compatibility, i18n and so on). Suggestions (here or on wiki) are welcome.
Jacopo
 
Posts: 5
Joined: Fri Aug 29, 2008 5:22 pm
Location: Pisa & Milan

Re: IE8 compatibility

Postby Jacopo on Sat Mar 28, 2009 4:30 pm

I must add that for some reason my code isn't correctly running in IE anyways.
Jacopo
 
Posts: 5
Joined: Fri Aug 29, 2008 5:22 pm
Location: Pisa & Milan

Re: IE8 compatibility

Postby mr_lundis on Mon Mar 30, 2009 9:02 pm

No, there's no work on IE 8 compatibility in the trunk. To be honest there's really not much work done at all on WYMeditor at the moment, all of the core devs are keeping busy with other things. For the time being adding an X-UA-Compatible meta tag would seam like a possible workaround - any kind of other patches/fixes/tips are welcome.

Nice to see you on github by the way!

Cheers ;)
Jonatan Lundin - designer, developer and forum moderator. You should follow me on Twitter!
mr_lundis
 
Posts: 335
Joined: Sun Dec 02, 2007 10:59 am
Location: Sweden

Re: IE8 compatibility

Postby totoro on Thu Apr 16, 2009 9:14 am

It seems to be a IE8 bug. See http://trac.wymeditor.org/trac/ticket/173
Temporary workaround applied, see r589.
totoro
 
Posts: 1
Joined: Thu Apr 16, 2009 9:10 am

Re: IE8 compatibility

Postby roundash on Fri Apr 17, 2009 10:50 am

I don't know whether the code has changed much from the alpha to beta version but I'm using 0.5-al and it works fine in IE8 without any compatability mode fixes.
roundash
 
Posts: 24
Joined: Wed May 30, 2007 4:13 pm
Location: Devon, UK


Return to Developers

Who is online

Users browsing this forum: No registered users and 1 guest

cron