Forum closed. New forum available at http://community.wymeditor.org/

bug avec la version svn

For those who prefer to speak French.

bug avec la version svn

Postby gtraxx on Mon Mar 10, 2008 6:16 pm

Bonjour j'ai pris la version svn car j'ai vu une correction apporté sur la prise en charge navigateur.
Cependant, j'ai repéré un bug assez important sous firefox (pas regardé sous les autres)
Voici l'erreur dans firebug:
Code: Select all
WYMeditor.WymClassMozilla is not a constructor
init()jquery.wymeditor.... (line 682)
editor([textarea#texte], Object)jquery.wymeditor.... (line 273)
(no name)()jquery.wymeditor.... (line 647)
e([textarea#texte], function(), undefined)jquery-1.2.3.pack... (line 11)
e(function(), undefined)jquery-1.2.3.pack... (line 11)
wymeditor(Object)jquery.wymeditor.... (line 645)
(no name)()news# (line 47)
e()jquery-1.2.3.pack... (line 11)
e()jquery-1.2.3.pack... (line 11)
e([function(), function(), function(), 3 more...], function(), undefined)jquery-1.2.3.pack... (line 11)
e()jquery-1.2.3.pack... (line 11)
[Break on this error] var WymClass = new WYMeditor.WymClassMozilla(this);

Avec la version stable je n'ai pas cela mais ce fichier n'existe pas non plus donc voila.
User avatar
gtraxx
 
Posts: 17
Joined: Thu Feb 28, 2008 1:54 am
Location: Heusy

Postby jfh on Mon Mar 10, 2008 8:57 pm

Hello, charges-tu l'ensemble des fichiers jquery.wymeditor.*.js (qui se trouvent dans trunk/src/wymeditor)?
Il y a des test pages dans trunk/src/test.
User avatar
jfh
Site Admin
 
Posts: 370
Joined: Sat Sep 23, 2006 8:43 pm
Location: Belgium

Postby gtraxx on Mon Mar 10, 2008 9:49 pm

Ahhh ok j'avais pas vu qu'il fallais les charger un à un :
Code: Select all
<script type="text/javascript" src="../wymeditor/jquery.wymeditor.js"></script>
<script type="text/javascript" src="../wymeditor/jquery.wymeditor.explorer.js"></script>
<script type="text/javascript" src="../wymeditor/jquery.wymeditor.mozilla.js"></script>
<script type="text/javascript" src="../wymeditor/jquery.wymeditor.opera.js"></script>
<script type="text/javascript" src="../wymeditor/jquery.wymeditor.safari.js"></script>

Mais ce serais bien d'ajouter un appel aux class directement dans le js principal.
Je vais tester si j'ai des bugs d'affichage :wink:
User avatar
gtraxx
 
Posts: 17
Joined: Thu Feb 28, 2008 1:54 am
Location: Heusy

Postby jfh on Mon Mar 10, 2008 9:54 pm

Il y a un fichier par browser pour faciliter le développement, et le travail en équipe.
L'ensemble du code est fusionné lors du build.
User avatar
jfh
Site Admin
 
Posts: 370
Joined: Sat Sep 23, 2006 8:43 pm
Location: Belgium

Postby gtraxx on Tue Mar 11, 2008 1:07 am

cela fonctionne nikel sous FF2 linux, je testerai sous les autres navigateurs car me souviens qu'avec safari j'avais des souçi :wink:
En tout cas parfait l'avancement du projet, et je ne déplore aucun problème avec le dernier jquery 1.2.3 :wink:
User avatar
gtraxx
 
Posts: 17
Joined: Thu Feb 28, 2008 1:54 am
Location: Heusy

Postby jfh on Tue Mar 11, 2008 8:42 pm

OK, merci pour le feedback.
User avatar
jfh
Site Admin
 
Posts: 370
Joined: Sat Sep 23, 2006 8:43 pm
Location: Belgium

Re: bug avec la version svn

Postby gtraxx on Tue Jul 15, 2008 11:34 pm

Comme promis voici un feed-back, j'ai jquery 1.2.6 pour tester la version svn.
Je remarque une nouveauté (resizable) seul souci pas moyen d'utiliser ce plugin, les fichiers sont de jquery ui 1.5b mais nous sommes à la 1.5.2 est ce que le bug viendrai de la ?
cela coince ici :
Code: Select all
$.getScript(jQueryPlugins[0]);

Si je trouve, je partage :D
User avatar
gtraxx
 
Posts: 17
Joined: Thu Feb 28, 2008 1:54 am
Location: Heusy

Re: bug avec la version svn

Postby gtraxx on Tue Jul 15, 2008 11:53 pm

j'ai trouvé l'erreur , j'ai utilisez les nouveau fichier de jquery ui et remplacer deux ligne dans jquery.wymeditor.resizable.js

Code: Select all
// Make an array of the external JavaScript files required by the plugin.
    var jQueryPlugins = [jQueryPath + '/jquery-ui.min.js',
                         jQueryPath + '/ui.resizable.js'];
   
    // First get the jQuery UI base file
    jQuery.getScript(jQueryPlugins[0]);

    // Get the jQuery UI resizeable plugin and then init the wymeditor resize
    // plugin. It is import to do the initialisation after loading the   
    // necessary jQuery UI files has finished, otherwise the "resizable" method
    // would not be available.
    jQuery.getScript(jQueryPlugins[1], function() {     
        jQuery(wym._box).resizable(final_options);
    });

C'est pas grand chose mais sa fonctionne :oops:
User avatar
gtraxx
 
Posts: 17
Joined: Thu Feb 28, 2008 1:54 am
Location: Heusy

Re: bug avec la version svn

Postby gtraxx on Wed Jul 16, 2008 10:30 am

Par souçi de faciliter j'ai ajouter les fichiers de jquery ui dans le dossier du plugin resizable, j'ai du donc modifier quelques lignes pour appeler les fichiers:
Code: Select all
// var jQueryPath = wym.computeJqueryPath().match(/^(.*)\/(.*)$/)[1];
    var WymPath = wym.computeWymPath().match(/^(.*)\/(.*)$/)[1];

    // Make an array of the external JavaScript files required by the plugin.
   /* var jQueryPlugins = [jQueryPath + '/jquery-ui.min.js',
                         jQueryPath + '/ui.resizable.js'];*/
   var jQueryPlugins = [WymPath + '/plugins/resizable/jquery-ui.min.js',
                         WymPath + '/plugins/resizable/ui.resizable.js'];

Par contre je pense qu'une condition serais vraiment pratique si les fichiers n'existe pas ou s'ils ne sont pas charger, genre un alert :wink:
User avatar
gtraxx
 
Posts: 17
Joined: Thu Feb 28, 2008 1:54 am
Location: Heusy


Return to French forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron