Forum closed. New forum available at http://community.wymeditor.org/

alt=""

For those who prefer to speak French.

alt=""

Postby ryuran on Tue Jul 01, 2008 3:13 pm

J'ai remarqué un certain problème bien embêtant au niveau de l'accessibilité du code généré.

Si on veux inserer une image en laissant le champ "texte alternatif" vide, l'attribut alt n'est pas créé.

Et quand on écrit alt="" directement dans le html, il est automatiquement supprimer quoi que l'on fasse.

Apparemment ce problème a déjà été soulevé sur le forum anglophone.
ryuran
 
Posts: 2
Joined: Tue Jul 01, 2008 3:04 pm

Re: alt=""

Postby jfh on Sat Jul 05, 2008 10:26 am

Il me semble que pour améliorer l'accessibilité du code généré, il suffirait de remplir correctement l'attribut alt...
User avatar
jfh
Site Admin
 
Posts: 370
Joined: Sat Sep 23, 2006 8:43 pm
Location: Belgium

Re: alt=""

Postby ryuran on Wed Nov 19, 2008 2:22 pm

Pour votre information si une image n'apporte pas d'information indispensable à la copréhension du contenu, il est plus juste d'avoir un attribut alt vide que de ne pas en avoir du tout ce qui laisserai aux visiteur ne voyant pas l'image le chemin menant à celle ci.
Dans mon cas c'est le portrait d'un personage. Si l'utilisateur ne peux pas voir l'image je ne vais pas mettre le nom de la personne dans l'attribut alt ce serait de la répétition inutile donc mauvais pour l'accessibilité. Et si je met "photo de ..." c'est encore plus stupid si l'utilisateur ne peux pas la voir.

alt est l'attribut de texte alternatif. On doit donc pouvoir ne pas en mettre par choix et non par default ou oublie.

Et de toute façon ne pas le mettre du tout rend la page invalide xhtml1.0 strict. Alors que le laisser vide est tout à fait correct selon les normes.
ryuran
 
Posts: 2
Joined: Tue Jul 01, 2008 3:04 pm


Return to French forum

Who is online

Users browsing this forum: No registered users and 4 guests

cron