Forum closed. New forum available at http://community.wymeditor.org/

Textarea only submits with HTML selected

Support forum for WYMeditor.

Textarea only submits with HTML selected

Postby mearso on Wed Jun 04, 2008 10:37 pm

Hi All

Having a strange problem , that when I hit submit the editor does not submit the text. However, If i hit the HTML button, then submit the submission works fine. The HTML selcetion, must be the last thing before a submit. Any ideas what this might be?

Using Ruby on Rails, and the textarea is being called with the class of 'wymeditor'

Any help to point me in the right direction to track this down is much appreciated.
mearso
 
Posts: 2
Joined: Wed Jun 04, 2008 10:27 pm

Re: Textarea only submits with HTML selected

Postby jfh on Thu Jun 05, 2008 7:01 pm

Hi, you've to put the 'wymupdate' class on the submit button.
See http://trac.wymeditor.org/trac/wiki/0.5 ... xplanation
User avatar
jfh
Site Admin
 
Posts: 370
Joined: Sat Sep 23, 2006 8:43 pm
Location: Belgium

Re: Textarea only submits with HTML selected

Postby mearso on Tue Jun 10, 2008 8:12 am

Thanks for that - adding that class has done the trick.
mearso
 
Posts: 2
Joined: Wed Jun 04, 2008 10:27 pm

Re: Textarea only submits with HTML selected

Postby smarques on Thu Jul 10, 2008 12:46 pm

Hi, is there any other way to have textarea submit correctly without having to set this class on the submit button?
smarques
 
Posts: 2
Joined: Thu Jul 10, 2008 12:45 pm

Re: Textarea only submits with HTML selected

Postby jfh on Mon Jul 14, 2008 6:23 pm

Yes, by using wym.update() whenever you want to update the element replaced by WYMeditor.
http://trac.wymeditor.org/trac/wiki/0.5/API#update
User avatar
jfh
Site Admin
 
Posts: 370
Joined: Sat Sep 23, 2006 8:43 pm
Location: Belgium


Return to Support

Who is online

Users browsing this forum: No registered users and 0 guests

cron