Forum closed. New forum available at http://community.wymeditor.org/

A few issues, jquery version

Support forum for WYMeditor.

A few issues, jquery version

Postby martinsarsini on Wed Sep 10, 2008 9:17 am

Dear everyone
I have problems using the jquery framework
I am using Google loader and the latest version of jquery, but I am getting errors if I am using the preview functionality and the insert table

Code: Select all
<script src="http://www.google.com/jsapi"></script>
<script>google.load("jquery", "1.2.6");</script>

I tryed also using google loader and jquery version 1.2.3 but nothing
it works only with the provided jquery.js file

But apart this, it doesn't post the data, I am using PHP and if I do a print_r($_POST) to see what values are posted, nothing in the textarea is being posted. If I deactivate Javascript it works, with WYMeditor it doesn't (even with the provided jquery.js file)
From that day on, if I was ever going somewhere, I was running!
My website of web developer
martinsarsini
 
Posts: 5
Joined: Wed Sep 10, 2008 9:13 am
Location: Glasgow

Re: A few issues, jquery version

Postby martinsarsini on Thu Sep 11, 2008 8:16 am

Good, I solved the problem of the data non posted
found out that I had to class="wymupdate" to che input submit

regarding the other problem, using google loader and jQuery 1.2.3 or 1.2.6, still haven't found out how to fix it
From that day on, if I was ever going somewhere, I was running!
My website of web developer
martinsarsini
 
Posts: 5
Joined: Wed Sep 10, 2008 9:13 am
Location: Glasgow

Re: A few issues, jquery version

Postby mr_lundis on Thu Sep 11, 2008 8:44 pm

martinsarsini wrote:I am using Google loader and the latest version of jquery, but I am getting errors if I am using the preview functionality and the insert table

You get this error because WYMeditor needs to include jQuery in all the pop-ups it opens and WYM does this by adding a script tag into the new window. So if you load jQuery dynamically, it won't work since WYMeditor needs the jQuery path to do this.

If you desperately need this functionality, I'd suggest you to post a ticket at the Trac site. However, just including jQuery locally will probably be a lot easier.

Hope this helps you out!
Jonatan Lundin - designer, developer and forum moderator. You should follow me on Twitter!
mr_lundis
 
Posts: 335
Joined: Sun Dec 02, 2007 10:59 am
Location: Sweden

Re: A few issues, jquery version

Postby martinsarsini on Fri Sep 12, 2008 2:06 pm

Yes i quite understood it was something like this.
Would be great if something can be done to make it work also with google loader, I think I am not the only one using it :D
From that day on, if I was ever going somewhere, I was running!
My website of web developer
martinsarsini
 
Posts: 5
Joined: Wed Sep 10, 2008 9:13 am
Location: Glasgow

Re: A few issues, jquery version

Postby Jaymon on Mon Oct 06, 2008 2:00 am

I use the Google Loader and solved this issue by just using the full googleapi url, which is:

http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js

I would assume you could update the 1.2.6 to whatever version of jquery you use. I found the full url here: http://code.google.com/apis/ajaxlibs/documentation/index.html#jquery
Jaymon
 
Posts: 2
Joined: Mon Oct 06, 2008 1:42 am

Re: A few issues, jquery version

Postby martinsarsini on Mon Oct 06, 2008 8:20 am

Of course in the way that you have describded it works because you are including the absolute path to the library, it doesn't matter where it is hosted. Your method is not using the google.load, but just using Google for the hosted library file. That is exactly where my problem is, I need to use the google.load method
From that day on, if I was ever going somewhere, I was running!
My website of web developer
martinsarsini
 
Posts: 5
Joined: Wed Sep 10, 2008 9:13 am
Location: Glasgow

Re: A few issues, jquery version

Postby martinsarsini on Mon Oct 06, 2008 8:31 am

anyway, I raised a ticket here http://trac.wymeditor.org/trac/ticket/128
From that day on, if I was ever going somewhere, I was running!
My website of web developer
martinsarsini
 
Posts: 5
Joined: Wed Sep 10, 2008 9:13 am
Location: Glasgow


Return to Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron